summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-25 20:09:45 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-25 20:11:05 +0100
commit1698ba5933326f9895504af33a94ac6ee8f5321d (patch)
treee55e57b765a99036905cdce1b247ae0dccc74d49 /tests
parentd29d82031f1e2907e219b04916112cd5236bc476 (diff)
Test suite: run-all: Ensure tests/tmp/ exists
ca007b4d "Test suite: run-all: record output" introduced a regression: if tests/tmp/ does not exist on entry, tests/run-all fails. So create it first. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
Diffstat (limited to 'tests')
-rwxr-xr-xtests/run-all2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/run-all b/tests/run-all
index c6df386..e53b963 100755
--- a/tests/run-all
+++ b/tests/run-all
@@ -13,6 +13,8 @@ if [ $# != 0 ]; then
set TESTSCRIPTS="$*"
fi
+mkdir -p tests/tmp
+
(
set -x
exec make $jcpus -k -f tests/Makefile "$@"