summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xinfra/dgit-repos-policy-debian2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a25dbba..7a70d86 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -32,6 +32,7 @@ dgit (0.31~~) unstable; urgency=low
Cleanups:
* Remove an obsolete comment from the code.
+ * Improve an error message from dgit-repos-policy-debian.
--
diff --git a/infra/dgit-repos-policy-debian b/infra/dgit-repos-policy-debian
index a0ac519..5b957d3 100755
--- a/infra/dgit-repos-policy-debian
+++ b/infra/dgit-repos-policy-debian
@@ -346,7 +346,7 @@ END
printdebug "|< ", $_ if $debuglevel>=2;
next if m/^\w+ missing$/;
- die unless m/^(\w+) (\w+) (\d+)\s/;
+ die "$_ ?" unless m/^(\w+) (\w+) (\d+)\s/;
my ($objid,$objtype,$nbytes) = ($1,$2,$3);
my $drop;