summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bb5db14..bca0690 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -17,6 +17,8 @@ dgit (2.12~) unstable; urgency=medium
Closes:#847658.
* By default, generate a DEP-14 tag as well as a dgit archive/*
tag, even in non-split-view quilt modes. Closes:#844129.
+ * Do not fail when cloning a package containing dangling symlinks.
+ Closes:#848512.
Test suite:
* Provide and use stunt lintian and debuild, to avoid lintian
diff --git a/dgit b/dgit
index 7996227..992d2da 100755
--- a/dgit
+++ b/dgit
@@ -3271,7 +3271,7 @@ sub clone_finish ($) {
runcmd qw(bash -ec), <<'END';
set -o pipefail
git ls-tree -r --name-only -z HEAD | \
- xargs -0r touch -r . --
+ xargs -0r touch -h -r . --
END
printdone "ready for work in $dstdir";
}