summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 44aedd2..49a72bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,7 @@ dgit (1.5~~) unstable; urgency=medium
to change for the dgit user.
New checks and improved behaviours:
+ * When running dpkg-buildpackage, cope if user specified -g or -G.
* dgit sbuild: check that the set of .changes files found is as we
expect, before calling mergechanges.
* dgit sbuild: Rename the used-up .changes files to `.inmulti' to
diff --git a/dgit b/dgit
index 9ac8d54..7ec09de 100755
--- a/dgit
+++ b/dgit
@@ -3058,7 +3058,7 @@ sub massage_dbp_args ($;$) {
push @newcmd, '-nc';
# and some combinations of -S, -b, et al, are errors, rather than
# later simply overriding earlier
- push @newcmd, '-F' unless grep { m/^-[bBASF]$/ } (@$cmd, @$xargs);
+ push @newcmd, '-F' unless grep { m/^-[bBASFgG]$/ } (@$cmd, @$xargs);
push @newcmd, @$cmd;
@$cmd = @newcmd;
}