summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit1
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e0764f5..42b2fd6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -40,6 +40,9 @@ dgit (0.23~) unstable; urgency=low
* Better documentation for quilt series handling.
+ * Strip `-b <branch>' from contents of Vcs-Git header, when setting up
+ the vcs-git remote. Closes:#759374.
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit b/dgit
index f6324e0..d936acd 100755
--- a/dgit
+++ b/dgit
@@ -1413,6 +1413,7 @@ sub clone ($) {
}
fetch_from_archive() or no_such_package;
my $vcsgiturl = $dsc->{'Vcs-Git'};
+ $vcsgiturl =~ s/\s+-b\s+\S+//g;
if (length $vcsgiturl) {
runcmd @git, qw(remote add vcs-git), $vcsgiturl;
}