summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Dgit.pm3
-rw-r--r--debian/changelog1
2 files changed, 3 insertions, 1 deletions
diff --git a/Debian/Dgit.pm b/Debian/Dgit.pm
index a3c2753..1bac97b 100644
--- a/Debian/Dgit.pm
+++ b/Debian/Dgit.pm
@@ -147,8 +147,9 @@ sub debugcmd {
sub dep14_version_mangle ($) {
my ($v) = @_;
- # DEP-14 2014-11-05 "Version Mangling"
+ # DEP-14 patch proposed 2016-11-09 "Version Mangling"
$v =~ y/~:/_%/;
+ $v =~ s/\.(?=\.|$|lock$)/.#/g;
return $v;
}
diff --git a/debian/changelog b/debian/changelog
index 5211a3c..4ee6485 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ dgit (2.12~) unstable; urgency=medium
GIT_ALTERNATE_OBJECT_DIRECTORIES in the pre-receive-hook.
* dgit-maint-merge(7): Explain how to change to this workflow
from an existing git workflow. [Sean Whitton] Closes:#847807.
+ * Version tags mangling: Protect dots, as per proposed update to DEP-14.
Test suite:
* Provide and use stunt lintian and debuild, to avoid lintian