summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 595e91e..6080f8f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,6 @@
dgit (0.21~~iwj) unstable; urgency=low
+ * Use failedcmd to report errors when ssh psql fails. Closes:#734281.
* Add `Testsuite: autopkgtest' to debian/control. (This will only have
the right effect with recent enought dpkg, and will generate a warning
with earlier versions of dpkg.
diff --git a/dgit b/dgit
index 61af3b8..94454d3 100755
--- a/dgit
+++ b/dgit
@@ -676,7 +676,7 @@ sub sshpsql ($$) {
printdebug("$debugprefix>|$_|\n");
push @rows, $_;
}
- $!=0; $?=0; close P or die "$! $?";
+ $!=0; $?=0; close P or failedcmd @cmd;
@rows or die;
my $nrows = pop @rows;
$nrows =~ s/^\((\d+) rows?\)$/$1/ or die "$nrows ?";