summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--tests/lib24
2 files changed, 25 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 90b157c..dee2b95 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (5.9+exp1) experimental; urgency=medium
* test suite: Use dch -r -D sid '' not dch -r sid. Closes:#903441.
+ * test suite: Save much stuff to $AUTOPKGTEST_ARTIFACTS.
--
diff --git a/tests/lib b/tests/lib
index e06ae22..87dd376 100644
--- a/tests/lib
+++ b/tests/lib
@@ -17,6 +17,8 @@ funcs: ${FUNCNAME[*]}
lines: ${BASH_LINENO[*]}
files: ${BASH_SOURCE[*]}
END
+ t-save-artifacts
+
exit 16
}
@@ -409,9 +411,31 @@ t-fscks () {
t-ok () {
: '========================================'
t-fscks
+ t-save-artifacts
echo ok.
}
+t-save-artifacts () {
+ artifacts="$AUTOPKGTEST_ARTIFACTS"
+ if [ x"$artifacts" = x ]; then return; fi
+ if [ x"tmp" = x ]; then return; fi
+ : '(((((((((( t-save-artifacts ))))))))))'
+ cp -a "$tmp"/. "$artifacts"/.
+ cd "$artifacts"/.
+ find . \( -name \*.tar -o -name \*.sample \) -print0 | \
+ xargs -0r rm -v
+ find . \( -name .git \
+ -o -path ./salsa/\* \
+ -o -path ./git/\*.git \
+ \) -type d \
+ \! -path '*/.git/*/.git' -exec sh -xec '
+ cd "$1"
+ "$2"/playtree-save-refs
+ git gc --prune=all
+ ' x '{}' "$troot" \;
+ : ')))))))))) t-save-artifacts ))))))))))'
+}
+
t-rm-dput-dropping () {
rm -f $tmp/${p}_${v}_*.upload
}