summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 741c055..3aa6a14 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,6 +11,7 @@ dgit (3.11~) unstable; urgency=high
the user's object store. In particular, core.sharedRepository.
Prompted by #867603.
* Clone multisuite works even without --no-rm-on-error. Closes:#867434.
+ * Work if "git init" does not create $GIT/info. Closes:#858054.
Important bugfixes to other components:
* dgit-badcommit-fixup: Honour core.sharedRepository. Closes:#867603.
diff --git a/dgit b/dgit
index 40b8e32..743e869 100755
--- a/dgit
+++ b/dgit
@@ -3380,6 +3380,7 @@ END
return;
}
my $af = ".git/info/attributes";
+ ensuredir '.git/info';
open GAO, "> $af.new" or die $!;
print GAO <<END or die $!;
* dgit-defuse-attrs