summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 791066d..491e80f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ dgit (6.5~) unstable; urgency=medium
* test suite: editing a test script overrides DGIT_TESTS_PROGRESSIVE.
* dgit: Rename --dgit-view-save to --save-dgit-view, leaving an alias.
* dgit: Provide print-unapplied-treeish subcommand.
+ * dgit: Improve error message for unknown suite, to suggest -d.
--
diff --git a/dgit b/dgit
index ddc2d6c..29d29d1 100755
--- a/dgit
+++ b/dgit
@@ -1078,7 +1078,7 @@ sub canonicalise_suite_ftpmasterapi {
} qw(codename name);
push @matched, $entry;
}
- fail "unknown suite $isuite" unless @matched;
+ fail "unknown suite $isuite, maybe -d would help" unless @matched;
my $cn;
eval {
@matched==1 or die "multiple matches for suite $isuite\n";