summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 780fe23..5d78d25 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (3.12~) unstable; urgency=medium
- *
+ Important bugfixes to dgit:
+ * Pass --no-renames to git diff-tree -z, avoiding potential trouble.
--
diff --git a/dgit b/dgit
index ccf5009..91172da 100755
--- a/dgit
+++ b/dgit
@@ -4891,7 +4891,7 @@ sub quiltify_trees_differ ($$;$$$) {
# a list of unrepresentable changes (removals of upstream files
# (as messages)
local $/=undef;
- my @cmd = (@git, qw(diff-tree -z));
+ my @cmd = (@git, qw(diff-tree -z --no-renames));
push @cmd, qw(--name-only) unless $unrepres;
push @cmd, qw(-r) if $finegrained || $unrepres;
push @cmd, $x, $y;