summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit8
2 files changed, 9 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 95f563b..9506e02 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ dgit (0.22~experimental1) experimental; urgency=low
* New git-check and git-create methods "true" which are no-ops.
* Bring forward push of the version tag ref so it happens alongside
the push of the suite branch ref.
+ * test-dummy-drs `distro': for testing dgit-push-responder. WIP.
* dgit-push-responder: WIP
--
diff --git a/dgit b/dgit
index 34257de..9936c5f 100755
--- a/dgit
+++ b/dgit
@@ -469,6 +469,14 @@ our %defcfg = ('dgit.default.distro' => 'debian',
'dgit-distro.test-dummy.archive-query' => "dummycat:$td/aq",
'dgit-distro.test-dummy.mirror' => "file://$td/mirror/",
'dgit-distro.test-dummy.upload-host' => 'test-dummy',
+ 'dgit-distro.test-dummy-drs.ssh' => "$td/ssh",
+ 'dgit-distro.test-dummy-drs.username' => "alice",
+ 'dgit-distro.test-dummy-drs.git-check' => "true",
+ 'dgit-distro.test-dummy-drs.git-create' => "true",
+ 'dgit-distro.test-dummy-drs.git-url' => "$td/git",
+ 'dgit-distro.test-dummy-drs.archive-query' => "dummycat:$td/aq",
+ 'dgit-distro.test-dummy-drs.mirror' => "file://$td/mirror/",
+ 'dgit-distro.test-dummy-drs.upload-host' => 'test-dummy',
);
sub cfg {