summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit4
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5ecee03..e0d986c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -53,6 +53,7 @@ dgit (1.5~~) unstable; urgency=medium
* Turn off git gc in the private working areas.
* Do not fail to do some important quilt processing in some
--quilt modes.
+ * Fix two calls to chdir without proper error checking.
* Fix a couple of bugs in error reporting.
Test suite:
diff --git a/dgit b/dgit
index d8ab871..cdf2e93 100755
--- a/dgit
+++ b/dgit
@@ -3777,12 +3777,12 @@ sub quilt_fixup_singlepatch ($$$) {
rmtree("debian/patches");
runcmd @dpkgsource, qw(-b .);
- chdir "..";
+ changedir "..";
runcmd @dpkgsource, qw(-x), (srcfn $version, ".dsc");
rename srcfn("$upstreamversion", "/debian/patches"),
"work/debian/patches";
- chdir "work";
+ changedir "work";
commit_quilty_patch();
}