summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit1
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4556644..708c68a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -29,6 +29,8 @@ dgit (3.0~) unstable; urgency=medium
* Use refs/dgit-fetch/DISTRO rather than refs/dgit-fetch/DISTRO,
which leads to less duplication and so less clutter.
* Enforce a reasonable syntax for nominal distro names.
+ * When generating orig+debian/patches view, copy debian/ from
+ HEAD. This makes less noise in diffs. Closes:#850095.
Docuentation [Sean Whitton]:
* dgit-sponsorship(7): Use --no-dep14tag. Closes:#849105.
diff --git a/dgit b/dgit
index 909ac95..d62694a 100755
--- a/dgit
+++ b/dgit
@@ -5416,6 +5416,7 @@ sub quilt_fixup_multipatch ($$$) {
rmtree '.pc';
+ runcmd @git, qw(checkout -f), $headref, qw(-- debian);
my $unapplied=git_add_write_tree();
printdebug "fake orig tree object $unapplied\n";