summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit5
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a0b54f9..aa06a7f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (0.9) unstable; urgency=low
* New cleaning arrangements.
* More comprehensive workaround for `3.0 (quilt)'.
+ * In push, double-check the .changes against the changelog.
--
diff --git a/dgit b/dgit
index df4ea91..6665298 100755
--- a/dgit
+++ b/dgit
@@ -849,6 +849,11 @@ sub dopush () {
($changesfile) = @cs;
}
}
+ my $changes = parsecontrol($changesfile,$changesfile);
+ foreach my $field (qw(Source Distribution Version)) {
+ $changes->{$field} eq $clogp->{$field} or
+ fail "changes field $field \`$changes->{$field}'"
+ " does not match changelog \`$clogp->{$field}'";
my $tag = debiantag($dversion);
if (!check_for_git()) {
create_remote_git_repo();