summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 7611fca..6d6c305 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ dgit (0.18.1) unstable; urgency=low
Bugfixes:
* sshpsql archive query method passes LANG=C. Closes:#729788.
+ * Subcommand program or argument options containing hyphens work.
+ (Eg, --dpkg-buildpackage:blah was previously incorrectly rejected.)
Packaging fixes:
* Depend on dput.
diff --git a/dgit b/dgit
index 088f5d2..0f372f2 100755
--- a/dgit
+++ b/dgit
@@ -1896,12 +1896,12 @@ sub parseopts () {
} elsif (m/^--since-version=([^_]+|_)$/) {
push @ropts, $_;
$changes_since_version = $1;
- } elsif (m/^--(\w+)=(.*)/s &&
+ } elsif (m/^--([-0-9a-z]+)=(.*)/s &&
($om = $opts_opt_map{$1}) &&
length $om->[0]) {
push @ropts, $_;
$om->[0] = $2;
- } elsif (m/^--(\w+):(.*)/s &&
+ } elsif (m/^--([-0-9a-z]+):(.*)/s &&
!$opts_opt_cmdonly{$1} &&
($om = $opts_opt_map{$1})) {
push @ropts, $_;