summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e98fd2f..95f563b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
dgit (0.22~experimental1) experimental; urgency=low
* New git-check and git-create methods "true" which are no-ops.
+ * Bring forward push of the version tag ref so it happens alongside
+ the push of the suite branch ref.
* dgit-push-responder: WIP
--
diff --git a/dgit b/dgit
index 3c56a3a..0a5de29 100755
--- a/dgit
+++ b/dgit
@@ -1435,6 +1435,7 @@ sub dopush () {
create_remote_git_repo();
}
runcmd_ordryrun @git, qw(push),access_giturl(),"HEAD:".rrref();
+ runcmd_ordryrun @git, qw(push),access_giturl(),"refs/tags/$tag";
runcmd_ordryrun @git, qw(update-ref -m), 'dgit push', lrref(), 'HEAD';
if (!$we_are_responder) {
@@ -1454,7 +1455,6 @@ sub dopush () {
sign_changes $changesfile;
}
- runcmd_ordryrun @git, qw(push),access_giturl(),"refs/tags/$tag";
my $host = access_cfg('upload-host','RETURN-UNDEF');
my @hostarg = defined($host) ? ($host,) : ();
runcmd_ordryrun @dput, @hostarg, $changesfile;