summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 1e14862..66f74cf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,7 @@
dgit (0.11) unstable; urgency=low
+ * Fix bug which would make quilt patch fixup fail if git status
+ produced "M" lines.
* Use "ftp.debian.org" not "http.debian.net" as the default Debian
archive. (http.debian.net tends to defeat certain kinds of cacheing,
and can also have more skew.)
diff --git a/dgit b/dgit
index d2a52f6..878065f 100755
--- a/dgit
+++ b/dgit
@@ -763,7 +763,7 @@ sub commit_quilty_patch () {
my $bad=0;
foreach my $l (split /\n/, $output) {
next unless $l =~ m/\S/;
- if ($l =~ m{^\?\? (.pc|debian/patches)}) {
+ if ($l =~ m{^(?:\?\?| M) (.pc|debian/patches)}) {
$adds{$1}++;
} else {
print STDERR "git status: $l\n";