summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a01051e..7668c10 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (3.3~) unstable; urgency=medium
Bugfixes:
* dgit: Remove a leftover debugging print.
+ * dgit: Set default dsc import distro when there is no Dgit field.
Packaging:
* Remove redundant Recommends on libtext-iconv-perl.
diff --git a/dgit b/dgit
index 5ca4a81..1f3179f 100755
--- a/dgit
+++ b/dgit
@@ -2814,6 +2814,7 @@ sub parse_dsc_field ($$) {
if (!defined $f) {
progress "$what: NO git hash";
+ $def_dsc_distro->();
} elsif (($dsc_hash, $dsc_distro, $dsc_hint_tag, $dsc_hint_url)
= $f =~ m/^(\w+)\s+($distro_re)\s+($versiontag_re)\s+(\S+)(?:\s|$)/) {
progress "$what: specified git info ($dsc_distro)";