summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rw-r--r--tests/lib4
-rwxr-xr-xtests/tstunt/dpkg-parsechangelog2
3 files changed, 5 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 65ecda4..a60f35a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -118,6 +118,7 @@ dgit (1.5~~) unstable; urgency=medium
* Provide better log output for certain failures.
* Many new tests (especially for new functionality).
* Add missing debhelper (>=8) to test suite's global Depends.
+ * tstunt arrangements: Fix mishandling of PERLLIB, etc.
--
diff --git a/tests/lib b/tests/lib
index 6668a1c..3294cdc 100644
--- a/tests/lib
+++ b/tests/lib
@@ -696,11 +696,13 @@ t-stunt-envvar () {
local var=$1
local tstunt=$2
eval '
- case "'$var'" in
+ case "$'$var'" in
"$tstunt:"*) ;;
*":$tstunt:"*) ;;
+ "") '$var'="$tstunt" ;;
*) '$var'="$tstunt:$'$var'" ;;
esac
+ export '$var'
'
}
diff --git a/tests/tstunt/dpkg-parsechangelog b/tests/tstunt/dpkg-parsechangelog
index 1abd00c..4d7cdf8 100755
--- a/tests/tstunt/dpkg-parsechangelog
+++ b/tests/tstunt/dpkg-parsechangelog
@@ -30,7 +30,7 @@ if (@ARGV) {
foreach my $k (qw(PATH PERLLIB)) {
my @opath = defined $ENV{$k} ? split /\:/, $ENV{$k} : ();
my @npath = grep { $_ ne $strip } @opath;
- @npath != @opath or die "$0 $k $ENV{$k} ?";
+ @npath != @opath or die "$0 $k ".($ENV{$k}//"(undef)")." ?";
$ENV{$k} = join ':', @npath;
}
die if $ENV{'DGIT_NO_TSTUNT_CLPARSE'}++;