summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit4
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 924e2d7..3596972 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (3.8~) unstable; urgency=medium
- *
+ Bugfixes:
+ * Make dgit-setup-* work in default distro.
--
diff --git a/dgit b/dgit
index cf27bb7..8e7f239 100755
--- a/dgit
+++ b/dgit
@@ -6338,21 +6338,25 @@ sub cmd_print_dgit_repos_server_source_url {
sub cmd_setup_mergechangelogs {
badusage "no arguments allowed to dgit setup-mergechangelogs" if @ARGV;
+ local $isuite = 'DGIT-SETUP-TREE';
setup_mergechangelogs(1);
}
sub cmd_setup_useremail {
badusage "no arguments allowed to dgit setup-useremail" if @ARGV;
+ local $isuite = 'DGIT-SETUP-TREE';
setup_useremail(1);
}
sub cmd_setup_gitattributes {
badusage "no arguments allowed to dgit setup-useremail" if @ARGV;
+ local $isuite = 'DGIT-SETUP-TREE';
setup_gitattrs(1);
}
sub cmd_setup_new_tree {
badusage "no arguments allowed to dgit setup-tree" if @ARGV;
+ local $isuite = 'DGIT-SETUP-TREE';
setup_new_tree();
}