summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit3
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 087dc21..aa98a41 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,8 @@ dgit (4.2~) experimental; urgency=medium
Sean Whitton] Closes:#856402.
Minor fixes:
+ * In split brain mode, with unexpected diffs, print dgit view
+ commitid in suggested diff rune. (HEAD is wrong.) Closes:#886443.
* Fix message about missing quilt cache entry to refer to
HEAD rather than tree, since dgit needs a commit. Closes:#884646.
* Fix grammar error in 4.1 changelog entry. [Sean Whitton]
diff --git a/dgit b/dgit
index 3a9b46c..aa8f771 100755
--- a/dgit
+++ b/dgit
@@ -4238,13 +4238,14 @@ END
my $r = system @diffcmd;
if ($r) {
if ($r==256) {
+ my $referent = $split_brain ? $dgithead : 'HEAD';
my $diffs = cmdoutput @git, qw(diff --stat), $tree, $dgithead;
fail <<END
HEAD specifies a different tree to $dscfn:
$diffs
Perhaps you forgot to build. Or perhaps there is a problem with your
source tree (see dgit(7) for some hints). To see a full diff, run
- git diff $tree HEAD
+ git diff $tree $referent
END
} else {
failedcmd @diffcmd;