summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit-repos-server4
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index cc02778..a14811d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,6 +18,9 @@ dgit (0.23~) unstable; urgency=low
forced command wrappers. Implicitly, this defines a new ssh-based
command protocol.
+ * dgit-repos-server: Handle ' ' in SSH_ORIGINAL_COMMAND (which some
+ git versions send, sigh).
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit-repos-server b/dgit-repos-server
index 3e74217..c70bc27 100755
--- a/dgit-repos-server
+++ b/dgit-repos-server
@@ -576,9 +576,9 @@ sub parseargsdispatch () {
(?: \S* / )?
( [-0-9a-z]+ )
\s+
- (?: \S* / )?
+ '? (?: \S* / )?
($package_re) \.git
- $
+ '?$
}ox
or reject "command string not understood";
my $method = $1;