summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit4
-rw-r--r--dgit.14
3 files changed, 10 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index cff48d1..7d24dcf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ dgit (0.22~experimental1) experimental; urgency=low
* Clone removes destination directory on error. Closes:#736153.
* Work with wheezy-backports (and keep squeeze-backports working too).
Closes:#736524.
+ * Work in read-only no-git-history mode with Ubuntu. You still have
+ to pass -dubuntu. Closes:#751781.
Minor improvements:
* Include canonicalised suite name in signed tag message.
diff --git a/dgit b/dgit
index 053c768..8744874 100755
--- a/dgit
+++ b/dgit
@@ -471,6 +471,8 @@ our %defcfg = ('dgit.default.distro' => 'debian',
'dgit-distro.debian.mirror' => 'http://ftp.debian.org/debian/',
'dgit-distro.debian.backports-quirk' => '(squeeze)-backports*',
'dgit-distro.debian-backports.mirror' => 'http://backports.debian.org/debian-backports/',
+ 'dgit-distro.ubuntu.git-check' => 'false',
+ 'dgit-distro.ubuntu.mirror' => 'http://archive.ubuntu.com/ubuntu',
'dgit-distro.test-dummy.ssh' => "$td/ssh",
'dgit-distro.test-dummy.username' => "alice",
'dgit-distro.test-dummy.git-check' => "ssh-cmd",
@@ -865,6 +867,8 @@ sub check_for_git () {
return $r+0;
} elsif ($how eq 'true') {
return 1;
+ } elsif ($how eq 'false') {
+ return 0;
} else {
badcfg "unknown git-check \`$how'";
}
diff --git a/dgit.1 b/dgit.1
index 712f36d..f9077ee 100644
--- a/dgit.1
+++ b/dgit.1
@@ -511,6 +511,10 @@ build and dgit push.
To a user looking at the archive, changes pushed using dgit look like
changes made in an NMU: in a `3.0 (quilt)' package the delta from the
previous upload is recorded in a new patch constructed by dpkg-source.
+.SH READ-ONLY DISTROS
+Distros which do not maintain a set of dgit history git repositories
+can still be used in a read-only mode with dgit. Currently Ubuntu
+is configured this way.
.SH PACKAGE SOURCE FORMATS
If you are not the maintainer, you do not need to worry about the
source format of the package. You can just make changes as you like