summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit4
-rwxr-xr-xinfra/dgit-repos-policy-debian17
3 files changed, 17 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 265ecb0..1fe13f4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ dgit (5.11~) unstable; urgency=medium
* test suite: unset VISUAL, which interferes. Closes:#904308.
* apt-get method: when apt does not update release files,
unconditionally print hint about noatime. Closes:#851873.
+ * messages: Be a lot more friendly about NEW in particular,
+ and also add a couple of `please's. Closes:#904448.
--
diff --git a/dgit b/dgit
index 9c58fdf..0c55655 100755
--- a/dgit
+++ b/dgit
@@ -3992,7 +3992,7 @@ sub splitbrain_pseudomerge ($$$$) {
$@ =~ s/^\n//; chomp $@;
print STDERR <<END;
$@
-| Not fast forward; maybe --overwrite is needed, see dgit(1)
+| Not fast forward; maybe --overwrite is needed ? Please see dgit(1).
END
finish -1;
}
@@ -5917,7 +5917,7 @@ sub quilt_fixup_multipatch ($$$) {
failed to apply your git tree's patch stack (from debian/patches/) to
the corresponding upstream tarball(s). Your source tree and .orig
are probably too inconsistent. dgit can only fix up certain kinds of
- anomaly (depending on the quilt mode). See --quilt= in dgit(1).
+ anomaly (depending on the quilt mode). Please see --quilt= in dgit(1).
END
}
diff --git a/infra/dgit-repos-policy-debian b/infra/dgit-repos-policy-debian
index 990abd2..e85e92c 100755
--- a/infra/dgit-repos-policy-debian
+++ b/infra/dgit-repos-policy-debian
@@ -334,10 +334,19 @@ sub action_push () {
if (deliberately('include-questionable-history')) {
return 0;
}
- die "\nPackage is in NEW and has not been accepted or rejected yet;".
- " use a --deliberately option to specify whether you are".
- " keeping or discarding the previously pushed history. ".
- " Please RTFM dgit(1).\n\n";
+ die <<END;
+
+Package is in NEW and has not been accepted or rejected yet.
+Unfortunately, we cannot determine automatically what should happen.
+You will have to pass either --deliberately-not-fast-forward or
+--deliberately-include-questionable-history to specify whether you are
+keeping or discarding the previously pushed history.
+
+The choice is important, to ensure that your git history is both
+suitable for public distribution and as useful as possible. Please
+see the descriptions of these options in dgit(1).
+
+END
}
sub action_push_confirm () {