summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ee5f7d0..7143fe7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -48,6 +48,7 @@ dgit (1.5~~) unstable; urgency=medium
source. Fixes bad Perl poetry syntax. Closes:#829121.
* When synthesing a commit from a .dsc from the archive, stop
internal git reset from printing a confusing message about HEAD.
+ * Turn off git gc in the private working areas.
Test suite:
* When sbuild fails, do not crash due to sed not finding the log
diff --git a/dgit b/dgit
index 39efa04..b1cb9b2 100755
--- a/dgit
+++ b/dgit
@@ -1340,6 +1340,7 @@ sub prep_ud (;$) {
sub mktree_in_ud_here () {
runcmd qw(git init -q);
+ runcmd qw(git config gc.auto 0);
rmtree('.git/objects');
symlink '../../../../objects','.git/objects' or die $!;
}