summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit-badcommit-fixup3
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4a13463..003b00e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (2.16.2~) unstable; urgency=medium
dgit-badcommit-fixup:
* Fix crash when running for 2nd time in bare repo.
+ * In --check mode, exit with status 2 if things are not fine.
--
diff --git a/dgit-badcommit-fixup b/dgit-badcommit-fixup
index 935f5df..0a1ebcf 100755
--- a/dgit-badcommit-fixup
+++ b/dgit-badcommit-fixup
@@ -298,4 +298,7 @@ if ($real >= 0) {
print "old values saved in refs/dgit-badcommit/\n" or die $!;
} elsif ($real == 0) {
print "testing output saved in refs/dgit-badfixuptest/\n" or die $!;
+} else {
+ print STDERR "found work to do, exiting status 2\n";
+ exit 2;
}