summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4c73fea..4940aa3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ dgit (3.5~) unstable; urgency=medium
* Improve comment left in .git/info/attributes.
* Defuse gitattributes in private working area even if we don't do it in
the user's tree because config setup-gitattributes=false.
+ * Do not print spurious warning about actually-defused gitattributes
+ when cloning. Closes:#851624.
--
diff --git a/dgit b/dgit
index dae194c..eb42b00 100755
--- a/dgit
+++ b/dgit
@@ -3601,6 +3601,7 @@ sub clone ($) {
mkdir $dstdir or fail "create \`$dstdir': $!";
changedir $dstdir;
runcmd @git, qw(init -q);
+ setup_new_tree();
clone_set_head();
my $giturl = access_giturl(1);
if (defined $giturl) {
@@ -3619,7 +3620,6 @@ sub clone ($) {
$vcsgiturl =~ s/\s+-b\s+\S+//g;
runcmd @git, qw(remote add vcs-git), $vcsgiturl;
}
- setup_new_tree();
clone_finish($dstdir);
}