summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit7
2 files changed, 9 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 84cf7de..b1a7cc5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,8 @@ dgit (0.9) unstable; urgency=low
* Change our .dsc field name to `Dgit'. Relevant to #720201.
* Fix bug handling our synthetic merges when we see them in
the remote suite branch.
+ * `3.0 (quilt)' fixup creates .pc/applied-patches since modern
+ dpkg-source creates it even though old ones didn't always.
--
diff --git a/dgit b/dgit
index c0c7b8d..3f9dd97 100755
--- a/dgit
+++ b/dgit
@@ -1016,6 +1016,13 @@ END
local $ENV{$fakeeditorenv} = cmdoutput qw(realpath --), $descfn;
runcmd_ordryrun @dpkgsource, qw(--commit .), $patchname;
}
+
+ if (!open P, '>', ".pc/applied-patches") {
+ $!==&ENOENT or die $!;
+ } else {
+ close P;
+ }
+
commit_quilty_patch();
}