summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xgit-debrebase4
-rw-r--r--git-debrebase.1.pod4
3 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 82f6acc..0afe46a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,9 @@ dgit (5.9~) unstable; urgency=medium
* git-debrebase convert-from-gbp: Look for dgit-generated tags so we can
usually make the new branch ff of the dgit view. Closes:#903132.
+ * git-debrebase convert-from-gbp: Check that the result will not
+ count as having diverged. This will usually turn failures to make
+ the ff pseudomerge into -fdiverged. Related to #903132.
--
diff --git a/git-debrebase b/git-debrebase
index 7b2e4f3..f002225 100755
--- a/git-debrebase
+++ b/git-debrebase
@@ -1658,7 +1658,7 @@ sub cmd_convert_from_gbp () {
print STDERR "cannot stitch in dgit view: $@\n";
}
- snags_maybe_bail();
+ snags_maybe_bail_early();
my $work;
@@ -1696,6 +1696,8 @@ sub cmd_convert_from_gbp () {
}
};
+ ffq_check $work;
+ snags_maybe_bail();
update_head_checkout $old_head, $work, 'convert-from-gbp';
}
diff --git a/git-debrebase.1.pod b/git-debrebase.1.pod
index d67e557..273ef47 100644
--- a/git-debrebase.1.pod
+++ b/git-debrebase.1.pod
@@ -265,6 +265,10 @@ your new git-debrebase view is appropriately fast forward.
The result is a well-formed git-debrebase interchange branch.
The result is also fast-forward from the gbp branch.
+It is a snag if the new branch looks like it will have diverged,
+just as for a laundering/unstitching call to git-debrebase;
+See L</Establish the current branch's ffq-prev>, below.
+
Note that it is dangerous not to know whether you are
dealing with a gbp patches-unappled branch containing quilt patches,
or a git-debrebase interchange branch.