summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a60be0d..21d7a97 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (0.14) unstable; urgency=low
* Include package name in tag message.
+ * Create directory .git/dgit when needed during build. Closes: #721428.
--
diff --git a/dgit b/dgit
index 46099d2..98fd04d 100755
--- a/dgit
+++ b/dgit
@@ -1055,6 +1055,7 @@ sub build_maybe_quilt_fixup () {
my $ncommits = 3;
my $patchname = "auto-$version-$headref-$time";
my $msg = cmdoutput @git, qw(log), "-n$ncommits";
+ mkpath '.git/dgit';
my $descfn = ".git/dgit/quilt-description.tmp";
open O, '>', $descfn or die "$descfn: $!";
$msg =~ s/\n/\n /g;