summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--tests/lib1
2 files changed, 7 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 663eca8..f5078be 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (5.9+exp3) experimental; urgency=medium
+
+ * test suite: chmod a+r $AUTOPKGTEST explicitly.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 13 Jul 2018 00:54:20 +0100
+
dgit (5.9+exp2) experimental; urgency=medium
* test suite: Save things to $AUTOPKGTEST_ARTIFACTS without
diff --git a/tests/lib b/tests/lib
index 1ddfcea..4425bf6 100644
--- a/tests/lib
+++ b/tests/lib
@@ -421,6 +421,7 @@ t-save-artifacts () {
if [ x"tmp" = x ]; then return; fi
: '(((((((((( t-save-artifacts ))))))))))'
cp -dR --preserve=links,timestamps "$tmp"/. "$artifacts"/.
+ chmod -R a+r -- "$artifacts"/.
cd "$artifacts"/.
find . \( -name \*.tar -o -name \*.sample \) -print0 | \
xargs -0r rm -v