summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog4
-rwxr-xr-xdgit9
-rw-r--r--dgit.17
3 files changed, 20 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7bae4d2..81059b5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,10 @@ dgit (4.1~) experimental; urgency=medium
worktrees on different filesystems may not work; that's a
matter for the future. Closes:#868515.
+ Other improvements to dgit:
+ * New print-dpkg-source-ignores option to print the big rune
+ you need to pass to dpkg-source to make it work exactly the right.
+
Documentation:
* dgit-user(7): Provide information about how to use sbuild.
Quite ugly due to #868527. Closes:#868526.
diff --git a/dgit b/dgit
index fc9dac7..3c94f03 100755
--- a/dgit
+++ b/dgit
@@ -6425,6 +6425,15 @@ sub cmd_print_dgit_repos_server_source_url {
print $url, "\n" or die $!;
}
+sub pre_print_dpkg_source_ignores {
+ not_necessarily_a_tree();
+}
+sub cmd_print_dpkg_source_ignores {
+ badusage "no arguments allowed to dgit print-dpkg-source-ignores"
+ if @ARGV;
+ print "@dpkg_source_ignores\n" or die $!;
+}
+
sub cmd_setup_mergechangelogs {
badusage "no arguments allowed to dgit setup-mergechangelogs" if @ARGV;
local $isuite = 'DGIT-SETUP-TREE';
diff --git a/dgit.1 b/dgit.1
index 2233d95..b3b887f 100644
--- a/dgit.1
+++ b/dgit.1
@@ -343,6 +343,13 @@ as actually being used on the dgit git server, as a git tree.
Prints the url used by dgit clone-dgit-repos-server.
This is hopefully suitable for use as a git remote url.
It may not be useable in a browser.
+.TP
+.BI "dgit print-dpkg-source-ignores"
+Prints the -i and -I arguments which must be passed to dpkg-souce
+to cause it to exclude exactly the .git diredcory
+and nothing else.
+The separate arguments are unquoted, separated by spaces,
+and do not contain spaces.
.SH OPTIONS
.TP
.BR --dry-run " | " -n