summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xtests/tstunt/gpg-withagent2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 8076ac0..3611845 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dgit (5.5+exp7) experimental; urgency=medium
+
+ * test suite: gpg-agent workaround: Send ps output to stderr (oops)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Fri, 29 Jun 2018 17:03:09 +0100
+
dgit (5.5+exp6) experimental; urgency=medium
* test suite: gpg-agent workaround: Cope if ps not found.
diff --git a/tests/tstunt/gpg-withagent b/tests/tstunt/gpg-withagent
index 3f56d08..4b2ee1a 100755
--- a/tests/tstunt/gpg-withagent
+++ b/tests/tstunt/gpg-withagent
@@ -3,7 +3,7 @@ set -ex
d () {
date --iso-8601=ns >&2
- ps -ef | grep gpg-agent ||: >&2
+ ps -ef | grep gpg-agent >&2 ||:
}
d