summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rw-r--r--tests/lib4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 8b88fb3..3dd38e4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -41,6 +41,8 @@ dgit (0.22~experimental1) experimental; urgency=low
* In rpush, on protocol error talking to build host, check if the
subprocess died and report differently if so. Closes:#736528.
* Fixed a manpage typo.
+ * When tests invoke dgit, use --dgit= so that subprocesses use our
+ dgit rather than system one.
Major new feature, currently stalled awaiting server infrastructure:
* dgit-repos-server: New program for receiving signed-tag-based
diff --git a/tests/lib b/tests/lib
index 5e64b99..e17be7f 100644
--- a/tests/lib
+++ b/tests/lib
@@ -105,10 +105,10 @@ t-archive () {
}
t-dgit () {
+ local dgit=${DGIT_TEST-dgit}
: '
-
{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{'
- ${DGIT_TEST-dgit} --dget:-u --dput:--config=$tmp/dput.cf \
+ $dgit --dgit=$dgit --dget:-u --dput:--config=$tmp/dput.cf \
-dtest-dummy $DGIT_TEST_OPTS ${DGIT_TEST_DEBUG--D} \
-k39B13D8A "$@"
: '}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}