summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdgit5
-rw-r--r--dgit.18
2 files changed, 13 insertions, 0 deletions
diff --git a/dgit b/dgit
index 73184fb..3ef4348 100755
--- a/dgit
+++ b/dgit
@@ -2802,6 +2802,11 @@ sub cmd_clone_dgit_repos_server {
exec @cmd or fail "exec git clone: $!\n";
}
+sub cmd_setup_mergechangelogs {
+ badusage "no arguments allowed to dgit setup-mergechangelogs" if @ARGV;
+ setup_mergechangelogs();
+}
+
#---------- argument parsing and main program ----------
sub cmd_version {
diff --git a/dgit.1 b/dgit.1
index 9029f46..0f3f9c7 100644
--- a/dgit.1
+++ b/dgit.1
@@ -198,6 +198,14 @@ You will need similar enough versions of dgit on the build-host and
the invocation host. The build-host needs gnupg installed, with your
public key in its keyring (but not your private key, obviously).
.TP
+.B dgit setup-mergechangelogs
+Configures a git merge helper for the file
+.B debian/changelog
+which uses
+.BR dpkg-mergechangelogs .
+You can use this in any git repository, not just ones used with
+the other dgit operations.
+.TP
.B dgit quilt-fixup
`3.0 (quilt)' format source packages need changes representing not
only in-tree but also as patches in debian/patches. dgit quilt-fixup