summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit5
2 files changed, 4 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 5174822..a45d633 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (5.7~) unstable; urgency=medium
- *
+ Bugfixes:
+ * dgit update-vcs-git: Honour --package properly.
--
diff --git a/dgit b/dgit
index db12d22..404eab9 100755
--- a/dgit
+++ b/dgit
@@ -4658,11 +4658,10 @@ sub cmd_update_vcs_git () {
}
}
- my $sourcep = parsecontrol 'debian/control', 'debian/control';
- $package = getfield $sourcep, 'Source';
+ package_from_d_control();
my $ctrl;
if ($specsuite eq '.') {
- $ctrl = $sourcep;
+ $ctrl = parsecontrol 'debian/control', 'debian/control';
} else {
$isuite = $specsuite;
get_archive_dsc();