summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit4
2 files changed, 5 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8294191..0155fa9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (6.2~) unstable; urgency=medium
* dgit(1): Improve and correct --build-products-dir description.
* dgit: Minor code cleanup.
+ * dgit build: Warn if --build-products-dir is not `..'. Closes:#904859.
* test suite: Test dgit import-dsc --build-products-dir.
--
diff --git a/dgit b/dgit
index 6312671..4e43d21 100755
--- a/dgit
+++ b/dgit
@@ -6294,6 +6294,10 @@ sub postbuild_mergechanges_vanilla ($) {
sub cmd_build {
build_prep_early();
+ $buildproductsdir eq '..' or print STDERR <<END;
+$us: warning: build-products-dir set, but not supported by dgit build
+$us: warning: things may go wrong or files may go to the wrong place
+END
my @dbp = (@dpkgbuildpackage, qw(-us -uc), changesopts_initial(), @ARGV);
my $wantsrc = massage_dbp_args \@dbp;
build_prep($wantsrc);