summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6a8534b..b0587c6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -65,6 +65,8 @@ dgit (0.23~) unstable; urgency=low
* Turn all perl warnings into errors using $SIG{__WARN__}.
+ * Show git config queries only with debuglevel 3 (-DDD) and higher.
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit b/dgit
index 009319a..9a63e65 100755
--- a/dgit
+++ b/dgit
@@ -531,7 +531,7 @@ sub cfg {
my @cmd = (@git, qw(config --), $c);
my $v;
{
- local ($debuglevel) = $debuglevel-1;
+ local ($debuglevel) = $debuglevel-2;
$v = cmdoutput_errok @cmd;
};
if ($?==0) {