summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit3
-rw-r--r--dgit.12
3 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index e14257f..f0a3cb2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (0.4~pre2) experimental; urgency=low
* Mangle debian/<version> tags the way git-buildpackage does
(as of git-buildpackage 0.5.5, 3c6bbd0f4992f8da).
+ * Support dgit-distro.<distro>.keyid config option.
--
diff --git a/dgit b/dgit
index c20ed35..78a0e31 100755
--- a/dgit
+++ b/dgit
@@ -815,6 +815,9 @@ sub dopush () {
print "[new .dsc left in $dscfn.tmp]\n";
}
if ($sign) {
+ if (!defined $keyid) {
+ $keyid = access_cfg('keyid','RETURN-UNDEF');
+ }
my @tag_cmd = (@git, qw(tag -s -m),
"Release $dversion for $csuite [dgit]");
push @tag_cmd, qw(-u),$keyid if defined $keyid;
diff --git a/dgit.1 b/dgit.1
index 28ec02e..ee78e1b 100644
--- a/dgit.1
+++ b/dgit.1
@@ -411,6 +411,8 @@ on the dgit command line.
.TP
.BI dgit-distro. distro .ssh
.TP
+.BI dgit-distro. distro .keyid
+.TP
.BR dgit.default. *
for each
.BR dgit-distro. \fIdistro\fR . *