summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile13
-rw-r--r--debian/control13
-rwxr-xr-xdebian/rules11
-rw-r--r--debian/tests/control2
-rw-r--r--po4a/po4a.cfg1
-rwxr-xr-xtests/tests/manpages-format2
7 files changed, 39 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
index 653c53e..a5e13ea 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,7 @@
tests/tmp
debian/tmp
debian/dgit
+debian/git-debpush
debian/git-debrebase
debian/dgit-infrastructure
debian/files
diff --git a/Makefile b/Makefile
index 890e371..380bdb0 100644
--- a/Makefile
+++ b/Makefile
@@ -60,6 +60,9 @@ GDR_PERLMODULES= \
GDR_MAN1PAGES=git-debrebase.1
GDR_MAN5PAGES=git-debrebase.5
+GDP_PROGRAMS=git-debpush
+GDP_MAN1PAGES=git-debpush.1
+
INFRA_PROGRAMS=dgit-repos-server dgit-ssh-dispatch \
dgit-repos-policy-debian dgit-repos-admin-debian \
dgit-repos-policy-trusting dgit-mirror-rsync
@@ -70,7 +73,8 @@ INFRA_PERLMODULES= \
Debian/Dgit/Policy/Debian.pm
MANPAGES=$(MAN1PAGES) $(MAN5PAGES) $(MAN7PAGES) \
- $(GDR_MAN1PAGES) $(GDR_MAN5PAGES)
+ $(GDR_MAN1PAGES) $(GDR_MAN5PAGES) \
+ $(GDP_MAN1PAGES)
all: $(MANPAGES) $(addprefix substituted/,$(PROGRAMS))
@@ -98,6 +102,10 @@ installdirs:
$(DESTDIR)$(txtdocdir) $(DESTDIR)$(absurddir) \
$(addprefix $(DESTDIR)$(perldir)/, $(dir $(PERLMODULES)))
+install-gdp: installdirs-gdp
+ $(INSTALL_PROGRAM) $(GDP_PROGRAMS) $(DESTDIR)$(bindir)
+ $(INSTALL_DATA) $(GDP_MAN1PAGES) $(DESTDIR)$(man1dir)
+
install-gdr: installdirs-gdr
$(INSTALL_PROGRAM) $(GDR_PROGRAMS) $(DESTDIR)$(bindir)
$(INSTALL_DATA) $(GDR_MAN1PAGES) $(DESTDIR)$(man1dir)
@@ -115,6 +123,9 @@ install-infra: installdirs-infra
$(INSTALL_DATA) $$m $(DESTDIR)$(perldir)/$${m%/*}; \
done
+installdirs-gdp:
+ $(INSTALL_DIR) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
+
installdirs-gdr:
$(INSTALL_DIR) $(DESTDIR)$(bindir) \
$(DESTDIR)$(man1dir) $(DESTDIR)$(man5dir) \
diff --git a/debian/control b/debian/control
index eef4dca..15c3cd4 100644
--- a/debian/control
+++ b/debian/control
@@ -37,6 +37,19 @@ Description: rebasing git workflow tool for Debian packaging
git-debrebase is a tool for representing in git, and manipulating,
Debian packages based on upstream source code.
+Package: git-debpush
+Depends: devscripts, git, gnupg, ${misc:Depends}
+Architecture: all
+Description: client script for git pushing to Debian-style archives
+ git-debpush is a script to create and push a specially formatted
+ signed git tag. The metadata in the tag indicates that the tagged
+ commit should be pushed (or "uploaded") to a Debian-style archive.
+ .
+ Tags generated by this script can be read by an intermediary service,
+ which performs any conversion that's needed (such as producing and
+ signing a .dsc and .changes), and then uploads the result to the
+ Debian-style archive on your behalf.
+
Package: dgit-infrastructure
Depends: ${misc:Depends}, perl, git-core, gpgv, chiark-utils-bin,
libjson-perl, libdigest-sha-perl, libdbd-sqlite3-perl, sqlite3,
diff --git a/debian/rules b/debian/rules
index 8beb109..ea2ceac 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,7 +36,9 @@ override_dh_auto_clean:
globalperl=/usr/share/perl5
-override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
+override_dh_auto_install: specpkg_install_gdp \
+ specpkg_install_gdr \
+ specpkg_install_infra
make install prefix=/usr DESTDIR=debian/dgit
make -C po install prefix=/usr DESTDIR=../debian/tmp \
SUPPRESS_PO_UPDATE=1 S=''
@@ -45,6 +47,8 @@ override_dh_auto_install: specpkg_install_gdr specpkg_install_infra
override_dh_missing:
dh_missing --fail-missing
+specpkg_install_gdp: p=git-debpush
+
specpkg_install_gdr: p=git-debrebase
specpkg_install_gdr: pm=GDR
@@ -55,6 +59,11 @@ define specpkg_install_common
make install-$(tok) prefix=/usr DESTDIR=debian/$(p) perldir=$(specperl)
endef
+specpkg_install_gdp: tok=gdp
+specpkg_install_gdp: specperl=/usr/share/dgit/gdp/perl5
+specpkg_install_gdp:
+ $(specpkg_install_common)
+
specpkg_install_%: tok=$*
specpkg_install_%: specperl=/usr/share/dgit/$(tok)/perl5
specpkg_install_%:
diff --git a/debian/tests/control b/debian/tests/control
index b3e1b32..0732e14 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -43,7 +43,7 @@ Depends: chiark-utils-bin, faketime, git-debrebase, git-buildpackage
Tests: manpages-format
Tests-Directory: tests/tests
-Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, bc, faketime, man-db, make, groff, git-debrebase
+Depends: dgit, dgit-infrastructure, devscripts, debhelper (>=8), fakeroot, build-essential, chiark-utils-bin, bc, faketime, man-db, make, groff, git-debrebase, git-debpush
Tests: defdistro-mirror mirror mirror-debnewgit mirror-private
Tests-Directory: tests/tests
diff --git a/po4a/po4a.cfg b/po4a/po4a.cfg
index f296e4c..47e8b13 100644
--- a/po4a/po4a.cfg
+++ b/po4a/po4a.cfg
@@ -16,3 +16,4 @@
[type: pod] ../dgit-sponsorship.7.pod $lang:translated/man/$lang/man7/dgit-sponsorship.7.pod master:file=dgit-sponsorship_7
[type: pod] ../git-debrebase.1.pod $lang:translated/man/$lang/man1/git-debrebase.1.pod master:file=git-debrebase_1
[type: pod] ../git-debrebase.5.pod $lang:translated/man/$lang/man5/git-debrebase.5.pod master:file=git-debrebase_5
+[type: pod] ../git-debpush.1.pod $lang:translated/man/$lang/man1/git-debpush.1.pod master:file=git-debpush_1
diff --git a/tests/tests/manpages-format b/tests/tests/manpages-format
index e58da51..ce9d4dc 100755
--- a/tests/tests/manpages-format
+++ b/tests/tests/manpages-format
@@ -3,7 +3,7 @@ set -e
autoimport=
. tests/lib
-t-dependencies man-db make groff git-debrebase
+t-dependencies man-db make groff git-debrebase git-debpush
cd $root