summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdgit5
1 files changed, 1 insertions, 4 deletions
diff --git a/dgit b/dgit
index 5cf5fec..3933cec 100755
--- a/dgit
+++ b/dgit
@@ -5893,17 +5893,14 @@ sub quiltify ($$$$) {
$index++) { }
$!==ENOENT or confess "$patchname$index $!";
- runcmd @git, qw(checkout -q), $cc;
- runcmd @git, qw(checkout -q), $target, qw(debian/changelog);
-
quiltify_make_dpkg_patch
$p->{Commit} ,$cc,
"$patchname$index", $author, $msg,
"Date: $commitdate\n".
"X-Dgit-Generated: $clogp->{Version} $cc\n";
- runcmd @git, qw(checkout -q), $cc, qw(debian/changelog);
}
+ runcmd @git, qw(checkout -q), $target;
}
sub build_maybe_quilt_fixup () {