summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rwxr-xr-xdgit2
-rwxr-xr-xtests/tests/push-source-with-changes4
3 files changed, 6 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index d936d22..f0b6919 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-dgit (5.11~) unstable; urgency=medium
+dgit (6.0~) unstable; urgency=medium
* test suite: unset VISUAL, which interferes. Closes:#904308.
* apt-get method: when apt does not update release files,
@@ -11,6 +11,9 @@ dgit (5.11~) unstable; urgency=medium
* dgit: Minor internal improvements.
* dgit: Rename --ignore-dirty to --include-dirty (leaving the old
name supported as a deprecated alias).
+ * dgit: Always build the source package ourselves, rather than
+ sometimes leaving that to the builder command. dgit will now
+ usually generate *_multi.changes rather than *_$arch.changes.
--
diff --git a/dgit b/dgit
index 56f1605..3afaf19 100755
--- a/dgit
+++ b/dgit
@@ -166,7 +166,7 @@ our $keyid;
autoflush STDOUT 1;
our $supplementary_message = '';
-our $need_split_build_invocation = 0;
+our $need_split_build_invocation = 1;
our $split_brain = 0;
END {
diff --git a/tests/tests/push-source-with-changes b/tests/tests/push-source-with-changes
index b9a3906..580ea3a 100755
--- a/tests/tests/push-source-with-changes
+++ b/tests/tests/push-source-with-changes
@@ -2,8 +2,6 @@
set -e
. tests/lib
-arch=$(dpkg-architecture -qDEB_BUILD_ARCH)
-
t-tstunt-parsechangelog
t-prep-newpackage example 1.0
@@ -18,7 +16,7 @@ t-ref-head
t-dgit --dpkg-buildpackage:-d build -F
t-expect-push-fail 'user-specified changes file is not source-only' \
-t-dgit -C ../${p}_1.0_${arch}.changes push-source --new
+t-dgit -C ../${p}_1.0_multi.changes push-source --new
# (2) try pushing a source-only changes file