summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xtests/tests/gdr-edits9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/tests/gdr-edits b/tests/tests/gdr-edits
index ffb3305..5388f04 100755
--- a/tests/tests/gdr-edits
+++ b/tests/tests/gdr-edits
@@ -8,6 +8,10 @@ t-setup-import gbp2gdr
cd $p
+v=2.0-3
+dch -v $v -m testing
+git commit -m changelog debian/changelog
+
t-git-debrebase analyse |tee ../anal.1
cat ../anal.1
@@ -24,6 +28,9 @@ for f in debian/zorkmid src.c; do
done
git commit -m 'MIXED add boths'
+dch -r sid
+git commit -m changelog debian/changelog
+
git tag t.before
t-git-debrebase
@@ -36,6 +43,8 @@ t-git-debrebase stitch --prose=wombat
t-gdr-branch-structure stitched
+t-dgit push-source
+
: todo 'more tests: convert dgit import new upstream version'
: todo 'more tests: convert dgit import same upstream version'
: todo 'more tests: other maint updated, we must fetch'