summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Debian/Dgit.pm2
-rw-r--r--debian/changelog1
2 files changed, 2 insertions, 1 deletions
diff --git a/Debian/Dgit.pm b/Debian/Dgit.pm
index fce2ceb..ac44b9a 100644
--- a/Debian/Dgit.pm
+++ b/Debian/Dgit.pm
@@ -196,7 +196,7 @@ sub failedcmd {
sub cmdoutput_errok {
die Dumper(\@_)." ?" if grep { !defined } @_;
debugcmd "|",@_;
- open P, "-|", @_ or die $!;
+ open P, "-|", @_ or die "$_[0] $!";
my $d;
$!=0; $?=0;
{ local $/ = undef; $d = <P>; }
diff --git a/debian/changelog b/debian/changelog
index 6ef374b..7537ba2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -58,6 +58,7 @@ dgit (1.1~~) unstable; urgency=low
pass -nc.
* Also suppress spurious runs of the clean target when building using
git-buildpackage.
+ * When exec fails, always print the program name in the error message.
Infrastructure:
* Infrastructure: Get mirroring right for fresh repos of existing