summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit8
2 files changed, 10 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d3d41b3..f404d5a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,9 @@ dgit (3.0~) unstable; urgency=medium
* dgit config handling: Honour command-line and context-provided
suite and distro more reliably and consistently.
+ Minor new feature:
+ * distro alias facility in config space. (Primarily for testing.)
+
dgit-badcommit-fixup:
* Do not investigate symrefs. Closes:#850547.
diff --git a/dgit b/dgit
index 3ffcf77..02d0b92 100755
--- a/dgit
+++ b/dgit
@@ -691,7 +691,7 @@ sub cfg {
"$us: distro or suite appears not to be (properly) supported";
}
-sub access_basedistro () {
+sub access_basedistro__noalias () {
if (defined $idistro) {
return $idistro;
} else {
@@ -711,6 +711,12 @@ sub access_basedistro () {
}
}
+sub access_basedistro () {
+ my $noalias = access_basedistro__noalias();
+ my $canon = cfg("dgit-distro.$noalias.alias-canon",'RETURN-UNDEF');
+ return $canon // $noalias;
+}
+
sub access_nomdistro () {
my $base = access_basedistro();
my $r = cfg("dgit-distro.$base.nominal-distro",'RETURN-UNDEF') // $base;