summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog15
-rw-r--r--dgit.122
-rw-r--r--tests/lib12
-rwxr-xr-xtests/setup/gdr-convert-gbp3
-rwxr-xr-xtests/setup/gdr-convert-gbp-noarchive1
-rwxr-xr-xtests/tests/gdr-newupstream1
-rwxr-xr-xtests/tests/gdr-viagit1
7 files changed, 40 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index 82c67d0..80fc035 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,15 @@
-dgit (5.3+exp1) experimental; urgency=low
+dgit (5.4) unstable; urgency=medium
- * No-change upload, for testing.
+ Improvements:
+ * dgit(1): Better description of --overwrite. Somewhat
+ apropos of discussion in #902534.
+
+ Bugfixes:
+ * test suite: gdr-viagit, gdr-newupstream: Do not spuriously
+ fail if gnupg not serendipitously installed. Closes:#902559.
+ * Fix bug ref to #865444 in previous changelog entry.
- -- Ian Jackson <ijackson@chiark.greenend.org.uk> Wed, 27 Jun 2018 23:11:30 +0100
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Wed, 27 Jun 2018 23:13:42 +0100
dgit (5.3) unstable; urgency=medium
@@ -18,7 +25,7 @@ dgit (5.3) unstable; urgency=medium
and a note about first dgit push in dgit(1). Closes:891031.
* dgit(7): Add discussion of quilt fixup error messages,
and add cross-references to dgit(1) and the actual error.
- Somewhat apropos of #842614.
+ Somewhat apropos of #865444.
-- Ian Jackson <ijackson@chiark.greenend.org.uk> Wed, 27 Jun 2018 14:00:31 +0100
diff --git a/dgit.1 b/dgit.1
index f15fecf..cbf0cde 100644
--- a/dgit.1
+++ b/dgit.1
@@ -514,11 +514,15 @@ push will still ensure that the .dsc you upload and the git tree
you push are identical, so this option won't make broken pushes.)
.TP
.BR --overwrite [=\fIprevious-version\fR]
-Declare that even though your git branch may not be a descendant
+Declare that your HEAD really does contain
+all the (wanted) changes
+from all versions listed in its changelog;
+or, all (wanted) changes from
+.IR previous-version .
+This promise is needed when
+your git branch is not a descendant
of the version in the archive
-according to the revision history,
-it really does contain
-all the (wanted) changes from that version.
+according to the git revision history.
This option is useful if you are the maintainer, and you have
incorporated NMU changes into your own git workflow in a way that
@@ -530,15 +534,19 @@ to a particular suite.
See
.BR dgit-maint- \fI*\fR (7) .
-.I previous-version
-ought to be the version currently in the archive. If
+If
.I previous-version
is not
specified, dgit will check that the version in the archive is
mentioned in your debian/changelog.
(This will avoid losing
-changes unless someone committed to git a finalised changelog
+changes, even with
+.BR --overwrite ,
+unless someone committed to git a finalised changelog
entry, and then made later changes to that version.)
+If
+.IR previous-version
+is specified, it ought to be the version currently in the archive.
dgit push --overwrite
will, if necessary, make a
diff --git a/tests/lib b/tests/lib
index bd06d20..f3fb0da 100644
--- a/tests/lib
+++ b/tests/lib
@@ -1134,7 +1134,11 @@ t-alt-test () {
t-git-config dgit.default.old-dsc-distro test-dummy
-case "$0" in
-*/gnupg) ;;
-*) t-setup-import gnupg ;;
-esac
+for import in ${autoimport-gnupg}; do
+ case "$0" in
+ */$import) ;;
+ *)
+ t-setup-import $import
+ ;;
+ esac
+done
diff --git a/tests/setup/gdr-convert-gbp b/tests/setup/gdr-convert-gbp
index 0b525c8..e523fd3 100755
--- a/tests/setup/gdr-convert-gbp
+++ b/tests/setup/gdr-convert-gbp
@@ -1,8 +1,11 @@
#!/bin/bash
set -e
+autoimport=
. tests/lib
. $troot/lib-gdr
+$ifarchive t-setup-import gnupg
+
t-dependencies GDR
t-tstunt-parsechangelog
diff --git a/tests/setup/gdr-convert-gbp-noarchive b/tests/setup/gdr-convert-gbp-noarchive
index dfeea3b..1d6758b 100755
--- a/tests/setup/gdr-convert-gbp-noarchive
+++ b/tests/setup/gdr-convert-gbp-noarchive
@@ -1,4 +1,5 @@
#!/bin/bash
+autoimport=
set -e
. tests/lib
. $troot/lib-gdr
diff --git a/tests/tests/gdr-newupstream b/tests/tests/gdr-newupstream
index cfa0052..ee987f5 100755
--- a/tests/tests/gdr-newupstream
+++ b/tests/tests/gdr-newupstream
@@ -1,5 +1,6 @@
#!/bin/bash
set -e
+autoimport=
. tests/lib
t-dependencies NO-DGIT GDR
diff --git a/tests/tests/gdr-viagit b/tests/tests/gdr-viagit
index 644d2d4..a83e622 100755
--- a/tests/tests/gdr-viagit
+++ b/tests/tests/gdr-viagit
@@ -1,5 +1,6 @@
#!/bin/bash
set -e
+autoimport=
. tests/lib
t-dependencies NO-DGIT GDR