summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b1c7db1..8f83173 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ dgit (3.6~) unstable; urgency=medium
Bugfixes:
* Actually use the url from a Dgit .dsc field naming an unknown distro.
Closes:#851728.
+ * Add dummy implementation of file_in_archive_aptget copied from
+ file_in_archive_dummycat. Re:#851697. [ Peter Green ]
Minor improvements:
* Use `confess' to print a stack trace in a couple of internal error
diff --git a/dgit b/dgit
index b7888af..b508ae6 100755
--- a/dgit
+++ b/dgit
@@ -1319,6 +1319,8 @@ sub archive_query_aptget {
return [ (getfield $pre_dsc, 'Version'), $uri ];
}
+sub file_in_archive_aptget () { return undef; }
+
#---------- `dummyapicat' archive query method ----------
sub archive_query_dummycatapi { archive_query_ftpmasterapi @_; }