summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit5
-rw-r--r--dgit.110
3 files changed, 12 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 706092b..af4893b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,6 +5,7 @@ dgit (2.5~) unstable; urgency=medium
actually identical. (Eg --quilt=gbp with no patches.) Closes:#841770.
* Switch to new archive/ tag format by default, even in
non-split-brain mode.
+ * Provide --gbp and --dpm as aliases for --quilt=gbp and --quilt=dpm.
Documentation:
* dgit-maint-merge(7): New tutorial manpage from Sean Whitton.
diff --git a/dgit b/dgit
index 5ee61ef..cc9a058 100755
--- a/dgit
+++ b/dgit
@@ -4608,7 +4608,7 @@ END
push @failsuggestion, "This might be a patches-applied branch.";
}
push @failsuggestion, "Maybe you need to specify one of".
- " --quilt=gbp --quilt=dpm --quilt=unapplied ?";
+ " --[quilt=]gbp --[quilt=]dpm --quilt=unapplied ?";
if (quiltmode_splitbrain()) {
quiltify_splitbrain($clogp, $unapplied, $headref,
@@ -5142,6 +5142,9 @@ sub parseopts () {
($om = $opts_opt_map{$1})) {
push @ropts, $_;
push @$om, $2;
+ } elsif (m/^--(gbp|dpm)$/s) {
+ push @ropts, "--quilt=$1";
+ $quilt_mode = $1;
} elsif (m/^--ignore-dirty$/s) {
push @ropts, $_;
$ignoredirty = 1;
diff --git a/dgit.1 b/dgit.1
index cd2075f..99ae90b 100644
--- a/dgit.1
+++ b/dgit.1
@@ -445,20 +445,24 @@ Do not check whether up source format `3.0 (quilt)' metadata needs
fixing up. If you use this option and the metadata did in fact need
fixing up, dgit push will fail.
.TP
-.BR --quilt=gbp " | " --quilt=dpm " | " --quilt=unapplied
+.BR -- [ quilt= ] gbp " | " -- [ quilt= ] dpm " | " --quilt=unapplied
Tell dgit that you are using a nearly-dgit-compatible git branch,
aka a
.BR "maintainer view" ,
and
do not want your branch changed by dgit.
-.B --quilt=gbp
+.B --gbp
+(short for
+.BR --quilt=gbp )
is for use with git-buildpackage.
Your HEAD is expected to be
a patches-unapplied git branch, except that it might contain changes
to upstream .gitignore files. This is the default for dgit gbp-build.
-.B --quilt=dpm
+.B --dpm
+(short for
+.BR --quilt=dpm )
is for use with git-dpm.
Your HEAD is expected to be
a patches-applied git branch,