summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rwxr-xr-xdgit9
2 files changed, 16 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a6729c6..3ecbbdb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+dgit (0.17~experimental4) experimental; urgency=low
+
+ * When using sbuild, pass the arguments to mergechanges in the right
+ order so that we use the correct Description (the _source one,
+ not the one from sbuild which didn't get e.g. -v<version>).
+
+ --
+
dgit (0.17~experimental3) experimental; urgency=low
Minor fix to remote functionality:
diff --git a/dgit b/dgit
index 37a6111..441114d 100755
--- a/dgit
+++ b/dgit
@@ -1759,7 +1759,14 @@ sub cmd_sbuild {
}
}
runcmd_ordryrun_local @sbuild, @ARGV, qw(-d), $isuite, $dscfn;
- runcmd_ordryrun_local @mergechanges, glob $pat;
+ my @changesfiles = glob $pat;
+ @changesfiles = sort {
+ ($b =~ m/_source\.changes$/ <=> $a =~ m/_source\.changes$/)
+ or $a cmp $b
+ } @changesfiles;
+ fail "wrong number of different changes files (@changesfiles)"
+ unless @changesfiles;
+ runcmd_ordryrun_local @mergechanges, @changesfiles;
my $multichanges = "${package}_".(stripepoch $version)."_multi.changes";
if (act_local()) {
stat $multichanges or fail "$multichanges: $!";